New Requester: Survey Link Issue "not found": Help Pls!

Titrate

New Member
Requester
Joined
Mar 25, 2017
Messages
9
Reaction score
2
Points
3
Age
29
Gender
Male
Some workers are seeing a "not found" message when they click on the survey link (linked from Qualtrics). Others complete the survey without any problems, any suggestions?
 

Jaded

The real themildone
Administrator
Joined
Jan 10, 2016
Messages
45,869
Reaction score
121,631
Points
1,414
Age
119
Gender
Female
Sometimes Qualtrics is a little buggy and when they get the "not found" they should clear their cookies and it should fix it.
 

Jaded

The real themildone
Administrator
Joined
Jan 10, 2016
Messages
45,869
Reaction score
121,631
Points
1,414
Age
119
Gender
Female
Also hello! And welcome to the forum!
 
  • Like
Reactions: Titrate

Leon Powalski

Active Member
Contributor
Joined
Jan 12, 2016
Messages
754
Reaction score
1,769
Points
518
Gender
Male
Another possible solution, in addition to what Jaded @Jaded mentioned, is that the survey link sometimes contains &MID={MTurk ID} at the end. Removing this part of the link has been known to solve this issue as well. I have encountered it myself, as has other members.
 
Last edited:
  • Like
Reactions: Jaded

Jaded

The real themildone
Administrator
Joined
Jan 10, 2016
Messages
45,869
Reaction score
121,631
Points
1,414
Age
119
Gender
Female
Another possible solution, in addition to what Jaded @Jaded mentioned, is that the survey link inserts &MID={MTurk ID} after the survey link. Removing this part of the link has been known to solve this issue as well. I have encountered it myself, as has other members.
Oh yeah, this is the other one that causes not found! Forgot about that one!
 

Titrate

New Member
Requester
Joined
Mar 25, 2017
Messages
9
Reaction score
2
Points
3
Age
29
Gender
Male
Another possible solution, in addition to what Jaded @Jaded mentioned, is that the survey link sometimes contains &MID={MTurk ID} at the end. Removing this part of the link has been known to solve this issue as well. I have encountered it myself, as has other members.
Thanks for the suggestions! You mean removing "&MID" in the source code? I thought that needed to be there?
 

Leon Powalski

Active Member
Contributor
Joined
Jan 12, 2016
Messages
754
Reaction score
1,769
Points
518
Gender
Male
Thanks for the suggestions! You mean removing "&MID" in the source code? I thought that needed to be there?
First of all, you're welcome. Second, welcome to the forum!

Unfortunately, I don't know enough about the source code side of things to be of much help, but the removing of that part of the link was a solution that some workers on this forum had found to circumvent the issue. I think this only began happening recently, as I've done surveys in the past where this did not happen. Perhaps there are other forum users who are able to speak about this from the source code perspective.
 
  • Like
Reactions: Titrate

Titrate

New Member
Requester
Joined
Mar 25, 2017
Messages
9
Reaction score
2
Points
3
Age
29
Gender
Male
First of all, you're welcome. Second, welcome to the forum!

Unfortunately, I don't know enough about the source code side of things to be of much help, but the removing of that part of the link was a solution that some workers on this forum had found to circumvent the issue. I think this only began happening recently, as I've done surveys in the past where this did not happen. Perhaps there are other forum users who are able to speak about this from the source code perspective.

I called Qualtrics. again. Ugh. They changed their anonymous links that removed the ? in the query string. So, going forward, everyone linking the Qualtrics link to MTurk surveys needs to add the ? at the end of the link. This replaces the "&" with "?"
 

electrolyte

The Ghost of MTurk Past
Contributor
Joined
Jan 10, 2016
Messages
19,184
Reaction score
45,968
Points
1,313
I called Qualtrics. again. Ugh. They changed their anonymous links that removed the ? in the query string. So, going forward, everyone linking the Qualtrics link to MTurk surveys needs to add the ? at the end of the link. This replaces the "&" with "?"
Oh, frustrating. Thanks for the follow up information though. At least now we know why this is happening!
 

Titrate

New Member
Requester
Joined
Mar 25, 2017
Messages
9
Reaction score
2
Points
3
Age
29
Gender
Male
Do you guys think I should approve the workers who received the error even though they didn't complete the survey? I'm still learning the etiquette when there's a technical issue..
 

electrolyte

The Ghost of MTurk Past
Contributor
Joined
Jan 10, 2016
Messages
19,184
Reaction score
45,968
Points
1,313
Do you guys think I should approve the workers who received the error even though they didn't complete the survey? I'm still learning the etiquette when there's a technical issue..
To clarify, you mean workers who didn't do the survey at all because of the URL problem but they submitted the HIT anyway?
 

electrolyte

The Ghost of MTurk Past
Contributor
Joined
Jan 10, 2016
Messages
19,184
Reaction score
45,968
Points
1,313
If they've contacted you about the problem, I'd send them the correct URL and ask them to complete it before you approve the HIT.

But if people were just submitting the HIT without doing the survey OR trying to contact you to figure out how to do it, then I don't see any reason to approve those people since they didn't do anything.
 
  • Like
Reactions: TheresaofAlbion

Titrate

New Member
Requester
Joined
Mar 25, 2017
Messages
9
Reaction score
2
Points
3
Age
29
Gender
Male
Okay, thank you. I can't ask them to try the link again bc the the batch is completed now :eek:
 

electrolyte

The Ghost of MTurk Past
Contributor
Joined
Jan 10, 2016
Messages
19,184
Reaction score
45,968
Points
1,313
Okay, thank you. I can't ask them to try the link again bc the the batch is completed now :eek:
Right, but I mean send them the correct Qualtrics link (not the MTurk HIT link) so that they can complete the survey for you before you approve their pending HIT.
 

sooner3k

New Member
Joined
Apr 3, 2017
Messages
1
Reaction score
0
Points
1
Location
Midwest, USA
Gender
Male
Hello everyone- My name is Vernon & I wanted to say:
  1. Salutations- Thank you for allowing me into your awesome forum!
  2. I myself have encountered these "link issues" several times, so this should be very useful advice.
I Emailed the requester with the details about the issue (it submitted automatically for some reason), but he did not send me the link to the survey, just the completed HIT link. I felt kind of bad actually, I hate to take someone's money for nothing.