reCAPTCHA not loading for me in surveys.

GiraffeKing

New Member
Joined
Sep 21, 2021
Messages
2
Reaction score
2
Points
3
Age
39
Gender
Male
This problem started randomly for me today. One survey the reCAPTCHA loaded normally, and then the next survey it did not. It has not worked for me in any surveys since then. I have tried using MTurk on multiple browsers, clearing cookies, and I have tried resetting my IP, and it is still happening. Since the reCAPTCHA will not load, not being able to click the "I am not a robot" box is preventing me from advancing in the surveys where it is included, and I am not sure what to do about it.

Also, I have not tried using a VPN to avoid this, because I want to maintain my high acceptance rating (only 6 hits rejected out of 5,818 HiTs, and those rejections were mostly subjective complaints related to writing tasks)
 
Last edited:
  • Like
Reactions: jan

jan

Moderator
Moderator
Joined
Jan 12, 2016
Messages
19,659
Reaction score
39,475
Points
1,463
Gender
Female
This problem started randomly for me today. One survey the reCAPTCHA loaded normally, and then the next survey it did not. It has not worked for me in any surveys since then. I have tried using MTurk on multiple browsers, clearing cookies, and I have tried resetting my IP, and it is still happening. Since the reCAPTCHA will not load, not being able to click the "I am not a robot" box is preventing me from advancing in the surveys where it is included, and I am not sure what to do about it.

Also, I have not tried using a VPN to avoid this, because I want to maintain my high acceptance rating (only 6 hits rejected out of 5,818 HiTs, and those rejections were mostly subjective complaints related to writing tasks)
mine didn't work for a few this morning. I think I tossed one back because of it. But it's been better this afternoon. I did check my adblocker - but I'm not sure that was the problem.